常見問題?

Flake8何時發布??

Flake8 釋放 必要時 . 有時有特定的目標和動力來實現發布。通常,我們在用戶報告和修復錯誤時發布。

如何幫助Flake8更快地釋放??

看看下一個里程碑。如果你能幫我們完成一些工作,那將幫助我們到達下一個里程碑。如果有一個阻止節目的錯誤需要發布,讓我們知道,但請友好。 Flake8 完全在志愿者時間內開發和發布。

Flake8的下一個版本是什么??

一般來說,我們嘗試使用里程碑來表示這一點。如果PyPI的最后一個版本是3.1.5,并且在GitLab中看到了3.2.0的里程碑,那么3.2.0很有可能是下一個版本。

為什么Flake8使用范圍作為依賴項??

Flake8 使用mccabe、pyflakes和pycodestyle的范圍,因為每個項目都傾向于添加 new 簽入次要版本。這是一個隱含的設計目標 Flake8 使錯誤代碼列表在其自己的小版本中保持穩定。這樣,如果您今天安裝了2.5系列中的某些內容,那么在一個月后再次安裝時,您將不會在同一系列中找到新的檢查。

Flake8 的依賴性傾向于避免補丁版本中的新檢查,這就是原因所在 Flake8 將其依賴關系大致表示為:

pycodestyle >= 2.0.0, < 2.1.0
pyflakes >= 0.8.0, != 1.2.0, != 1.2.1, != 1.2.2, < 1.3.0
mccabe >= 0.5.0, < 0.6.0

這使得這些項目可以發布修補程序版本來修復bug和 Flake8 用戶使用這些修復程序。

當依賴項的新版本可用時,我應該提交問題嗎??

No. 目前的Flake8核心團隊(一人)也是pycodestyle、pyflakes和mccabe的核心開發人員。他們知道這些發布。